Re: apache and php installation problem
| From: | Chris Hewitt | Date: | Sun, 10 Mar 2002 14:35:01 +0000 |
| Subject: | Re: apache and php installation problem | ||
| References: | 1 | Groups: | php.general |
| Request: | Send a blank email to php-general+get-87902@lists.php.net to get a copy of this message | ||
Duncan,
Just a thought, does the user that apache is running as have permissions to read/execute the file?
Regards
Chris
Duncan wrote:
Hi, i currently installed latest apache and php on my RH 7.2 system. However, i allways get the following error now: /usr/local/apache/bin/apachectl configtest Syntax error on line 216 of /usr/local/apache/conf/httpd.conf: Cannot load /usr/local/apache/libexec/libphp4.so into server: €Ø+@€Ø+@((Ø+@Ø+@˜Ø+@˜Ø+@ Ø+@ Ø+@¨Ø+@¨Ø+@°Ø+@°Ø+@¸Ø+@¸Ø+@ÀØ +@ÀØ+@ÈØ+@ÈØ+@ÐØ+@ÐØ+@ØØ+@ØØ+@àØ+@àØ+@èØ+@èØ+@ðØ+@ðØ+@øØ+@øØ +@: shared object not open The error_log says: Cannot load /usr/local/apache/libexec/libphp4.so into server: /usr/local/apache/libexec/libphp4.so: cannot open shared object file: No such file or directory ...but the file IS there! I don't understand this error. I had to comment all php-based lines within the httpd.conf file, to get apache up and running again! My problem is, that i need to get php up and running asap, so any help is more than welcome. Thanks in advance, regards, Duncan :wq