Re: "undefined symbol: compress" during install?
| From: | Erik Price | Date: | Mon, 11 Mar 2002 22:58:25 +0000 |
| Subject: | Re: "undefined symbol: compress" during install? | ||
| References: | 1 | Groups: | php.general |
| Request: | Send a blank email to php-general+get-88111@lists.php.net to get a copy of this message | ||
On Monday, March 11, 2002, at 05:21 PM, Erik Price wrote:
I just finished doing my re-install of PHP, updated to 4.1.2. Or so I thought... everything went smoothly, I got all the right success messages during the ./configure and make processes, and thought I was ready to go -- but as I confidently started up Apache, I was greeted with this message: [root@media src]# /usr/local/apache/bin/apachectl start Syntax error on line 222 of /usr/local/apache/conf/httpd.conf: Cannot load /usr/local/apache/libexec/libphp4.so into server: /usr/local/apache/libexec/libphp4.so: undefined symbol: uncompress /usr/local/apache/bin/apachectl start: httpd could not be startedHo! I have just RTFG'd, which I wish I had done before posting. Looks like I have omitted the --with-zlib parameter in the ./configure of PHP. I had it last time b/c I was following a tutorial, and omitted it this time since I didn't think I needed it. Actually, I had no idea what the zlib did for PHP so I figured why bother. I just re-did everything, but this time I used --with-zlib, and it's fine. Hope this helps someone else in the future -- and for anyone else who wants a fully-documented, commented log of an upgrade from PHP 4.1.0 to PHP4.1.2, contact me. (I did it with PHP as a static module to apache, and the following config options: --with-mysql, --with-xmlrpc, --enable-sockets, --with-zlib) Erik ---- Erik Price Web Developer Temp Media Lab, H.H. Brown pricee@hhbrown.com