Re: lookup -> php_lookup()?

From: Date: Sat, 17 Jun 2006 15:36:54 +0000
Subject: Re: lookup -> php_lookup()?
References: 1 2  Groups: php.gtk.dev 
Request: Send a blank email to php-gtk-dev+get-3061@lists.php.net to get a copy of this message
GtkIconFactory suffers in the same way. Can't we just rename the lookup methods? There's already a GdkPixmap::pixmap_lookup() so why not GdkWindow::window_lookup(), GtkIconFactory::lookup_icon_set() and GtkTextTagTable::lookup_tag()?
Yes, that's the culprit. They need to be declared in a different way.. I'll have to take a look at it. -Andrei On Jun 13, 2006, at 12:49 PM, Christian Weiske wrote:
Hi all, We have two class methods with name "lookup" that come out as "php_lookup" (GdkWindow and GtkTextTagTable). I think it's php_compat.h that defines
#define lookup                         php_lookup
Could that be? http://cvs.php.net/viewcvs.cgi/php-src/main/php_compat.h? view=markup&rev=1.29 -- Regards/MfG, Christian Weiske
-- PHP-GTK Development Mailing List (http://gtk.php.net/) To unsubscribe, visit: http://www.php.net/unsub.php __________ NOD32 1.1380 (20060125) Information __________ This message was checked by NOD32 antivirus system. http://www.eset.com


« previous php.gtk.dev (#3061) next »