Please don't use _marshal suffix for helper function like these. This
suffix should be reserved only for callback marshallers.
I actually did this last night, as I was looking over it and thinking about the definition of a marshaller.
While this works, it's not how the objects should be constructed.
Oh. Though it does work without any apparent problems...
in case this code runs on a subclass of GtkScaleButton
... and was GtkVolumeButton, but sure I'll look those up, and trace though what source makes construction in this manner more correct.
Do we need to duplicate the strings when adding them to the list?
String duplication? What kind of dork would waste CPU time on that?
/me covertly starts hitting the backspace key.
--
Bob Majdak Jr
KateOS Rofflecopter Pilot
http://www.kateos.org