#40570 [Opn->Bgs]: GtkCellLayout inherition

From: Date: Sun, 16 Mar 2008 15:20:09 +0000
Subject: #40570 [Opn->Bgs]: GtkCellLayout inherition
References: 1  Groups: php.gtk.dev 
Request: Send a blank email to php-gtk-dev+get-4190@lists.php.net to get a copy of this message
ID: 40570 Updated by: auroraeosrose@php.net Reported By: theredtitan at hotmail dot com -Status: Open +Status: Bogus Bug Type: PHP-GTK related Operating System: Windows XP SP2 PHP Version: 5.2.1 New Comment: Thank you for taking the time to write to us, but this is not a bug. Please double-check the documentation available at http://www.php.net/manual/ and the instructions on how to report a bug at http://bugs.php.net/how-to-report.php This is a configuration error if you "configured the error logger to hide errors and log in to a file on my machine" you need to check your logs to discover why you get a "blank page" - in this case probably apache usually doesn't have access to your X display so when php-gtk is loaded you get a fatal error The correct fix is to configure your machine so apache doesn't load the PHP-GTK extension Previous Comments: ------------------------------------------------------------------------ [2007-02-25 13:33:18] auroraeosrose at gmail dot com It's not a bug that php-gtk2 only works with the php cli sapi.... Perhaps it needs to throw an error when people attempt to load it with any other sapi "This only works with the cli version of PHP" ------------------------------------------------------------------------ [2007-02-25 12:44:07] yehac at hotmail dot com This is a nice work around, but this does not fix the bug that we need to!!! ------------------------------------------------------------------------ [2007-02-21 12:51:36] auroraeosrose at gmail dot com First of all, make sure you use the cli version of php (php.exe or php-win32.exe on windows..) with php-gtk2 - it is NOT meant to be used with a webserver or a webserver SAPI (isapi, apache2_2 module, cgi...etc)! If you're running both a webserver AND php-gtk on the same machine you're going to need to use different php.ini files, your webserver ini file should NOT be loading the php-gtk2.dll You can do this easily by setting the PHPINIDIR directive in your apache conf file or by renaming your php-gtk specific ini file php-cli.ini (a little known feature on windows is that php looks for sapi specific ini files - I have a php.ini, a php-isapi.ini, and a php-cli.ini all in the same directory...and IIS, apache, and the php cli always find the right file ;) ------------------------------------------------------------------------ [2007-02-21 01:36:12] theredtitan at hotmail dot com Description: ------------ First of all, sorry for my bad english!! I use PHP5 in both server side (With Apache 2.2), and client side (Using PHP-GTK) After I installed the PHP-GTK v2.0 on my PHP 5.2.1, accedently the logos of both PHP and Zend that appears on the page of "phpinfo.php" has disappeared!! I found that error occured when I added the "php.ini" setting: extension=php-gtk2.dll My error logs has repoted the following error: [21-Feb-2007 04:18:43] PHP Fatal error: Cannot inherit previously-inherited constant gtype from interface GtkCellLayout in Unknown on line 0 Reproduce code: --------------- <?php phpinfo(); ?> Expected result: ---------------- I expected to see the PHP and Zend logo with this codes: phpinfo.php?=PHPE9568F34-D428-11d2-A769-00AA001ACF42 phpinfo.php?=PHPE9568F35-D428-11d2-A769-00AA001ACF42 Actual result: -------------- What I saw when I query the "phpinfo.php" page was a blank page (As I configured the error logger to hide errors and log in to a file on my machine) ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=40570&edit=1

« previous php.gtk.dev (#4190) next »