php 4.3.2 and apache 1.3.27?
| From: | Gedanken | Date: | Wed, 16 Jul 2003 19:37:57 +0000 |
| Subject: | php 4.3.2 and apache 1.3.27? | ||
| Groups: | php.install | ||
| Request: | Send a blank email to php-install+get-11288@lists.php.net to get a copy of this message | ||
I asked my isp to upgrade their 4.1.2 php to 4.3.2 because I am working on
a code porting project that I am told 'needs' 4.3.2. It definitely doesnt
seem to work so far with out it... socket code problems.
anyway, i sent a note to my admin and he replied with the following
(edited by me):
---
We also have Apache 1.3.27 on RedHat 7.3 running on those same webservers
and I don't believe that PHP 4.3.2 will run on those versions. We
recently attempted to build a webserver running RedHat 8.0, Apache 2.0,
and PHP 4.2.1. The build failed because the versions of Apache and PHP
were unstable together.
We plan on consolidating our webservers into one large, powerful server,
one which hopefully will be running the latest and greatest versions of
apache and php. If you konw of any successful builds of Redhat, apache
and php or if there is a build of php 4.3.2 that will work with Apache
1.3, then I'll be more than happy to upgrade.
---
what can i tell him? How is the current 4.3.2 php with apache 1.3.27 and
redhat 7.3?
also, to get into more detail, im not even sure why i need apache. its
not a web based application... its just a little script that opens sockets
and polls either other socket apps or other webservers to download pages
for me. its run as a daemon, not executed as a cgi. in perl lingo (my
background), its a script not a cgi. can i try installing some CLI only
version of php and just skip this webserver issue? seems crazy i am
forced to have a webserver installed to install a scripting interpreter
that will never use it.
--
gedanken