Can't build PHP enabled Apache on Solaris8
| From: | John Ruff | Date: | Sat, 01 Sep 2001 05:34:51 +0000 |
| Subject: | Can't build PHP enabled Apache on Solaris8 | ||
| Groups: | php.install | ||
| Request: | Send a blank email to php-install+get-4146@lists.php.net to get a copy of this message | ||
I'm trying to build a Apache 1.3.20 server with the enable PHP 4.0.6 module.
I'm starting with both sources to perform the builds. I've followed the
install procedure found in the "php_manual_en.pdf" and on the website at
"http://www.php.net/FAQ.php". By the time
I get to the portion of building
apache, after building php, my 'make' fails with following excerpt:
[...SNIP...]
===> src/modules/php4
gmake[4]: Entering directory
`/export/home3/pkgs/apache_1.3.20/src/modules/php4'
gcc -c -I../../os/unix -I../../include -DSOLARIS2=280 -DUSE_EXPAT
-I../../lib/expat-lite -DNO_DL_NEEDED
../../apaci mod_php4.c
mod_php4.c:28: zend.h: No such file or directory
mod_php4.c:29: php.h: No such file or directory
mod_php4.c:30: php_variables.h: No such file or directory
mod_php4.c:47: php_ini.h: No such file or directory
mod_php4.c:48: php_globals.h: No such file or directory
mod_php4.c:49: SAPI.h: No such file or directory
mod_php4.c:50: php_main.h: No such file or directory
mod_php4.c:52: zend_compile.h: No such file or directory
mod_php4.c:53: zend_execute.h: No such file or directory
mod_php4.c:54: zend_highlight.h: No such file or directory
mod_php4.c:55: zend_indent.h: No such file or directory
mod_php4.c:57: ext/standard/php_standard.h: No such file or directory
gmake[4]: *** [mod_php4.o] Error 1
gmake[4]: Leaving directory
`/export/home3/pkgs/apache_1.3.20/src/modules/php4'
gmake[3]: *** [all] Error 1
gmake[3]: Leaving directory `/export/home3/pkgs/apache_1.3.20/src/modules'
gmake[2]: *** [subdirs] Error 1
gmake[2]: Leaving directory `/export/home3/pkgs/apache_1.3.20/src'
gmake[1]: *** [build-std] Error 2
gmake[1]: Leaving directory `/export/home3/pkgs/apache_1.3.20'
gmake: *** [build] Error 2
#
[...end SNIP...]
Yes...the files don't exist. Should they? Or should it not be trying to
make mod_php4.c, b/c there is already a mod_php4.o.
Please tell me about any "known-to-work' method for building a php enabled
apache 1.3.20 server on Solaris8.
Best Regards,
John Ruff