PHP-error after installing everything
| From: | Pieter | Date: | Sat, 13 Oct 2001 17:43:35 +0000 |
| Subject: | PHP-error after installing everything | ||
| Groups: | php.install | ||
| Request: | Send a blank email to php-install+get-4622@lists.php.net to get a copy of this message | ||
Hi mates,
I've got a little problem. I've installed Apache 1.3.22 for Windows, all
pretty succesful. After that I installed Perl, all goes well. When I start
Apache I can run the perl files so everything goes well. But now I've
unpacked the php-set into the root and I want to run all the php-files on
the server too. I've added these lines to the http.conf:
AddType application/x-httpd-php3 .php3
AddType application/x-httpd-php3-source .phps
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps
Action application/x-httpd-php3 "\php\php.exe"
Action application/x-httpd-php "c:\root\php\php.exe"
AddHandler application/x-httpd-php .php
AddHandler application/x-httpd-php3 .php3
And I've copied the php.ini to my windows directory (I'm using Windows XP
bytheway). I've edited these lines in the php.ini files:
include_path = "c:\root\php"
doc_root = "c:\root\php\"
extension_dir = "c:\root\php\extensions"
My php-directory (with the php.exe and the dll's etc) are in c:\root\php
My Apache server is in directory c:\root\apache
And my root for when I'm visiting the server is c:\root\1
Well, the problem is that when I start a php file, when I'm visiting my
http-server, I get the 'page not found'-error and when I look into my
log-file, I have this error:
[Sat Oct 13 18:47:39 2001] [error] [client xxx.xxx.xxx.xxx] Invalid URI in
request GET /php/1.php HTTP/1.1
Could someone help me please? What am I doing wrong?
Thanks in advance,
Kind regards,
Pieter