Re: troubles starting apache... with php 4.0.6
| From: | Mark John Buenconsejo | Date: | Fri, 31 Dec 1999 21:00:02 +0000 |
| Subject: | Re: troubles starting apache... with php 4.0.6 | ||
| References: | 1 | Groups: | php.install |
| Request: | Send a blank email to php-install+get-4809@lists.php.net to get a copy of this message | ||
Hello,
I got the same problem, do any of you guys know a solution?
Thanks!
Mark
"Walter Karpf" <walter.karpf@vienna.at> wrote in message
news:20011009174824.84685.qmail@pb1.pair.com...
> installing php4 did work well. but when i try to start apache with
> php4-module, i recieve this error:
>
> "Cannot load /usr/apache/libexec/libphp4.so into server: ld.so.1:
> /usr/apache/bin
> /httpd: fatal: relocation error: file /ust/apache/libexec/libphp4.so:
symbol
> uncompress: referenced symbol not fount"
>
> when i run "ldd -d /usr/apache/libexec/libphp4.so", i got this messages:
>
> symbol not found: uncompress (/usr/apache/libexec/libphp4.so)
> symbol not found: compress (/usr/apache/libexec/libphp4.so)
> symbol not found: ap_block_alarms (/usr/apache/libexec/libphp4.so)
> symbol not found: ap_unblock_alarms (/usr/apache/libexec/libphp4.so)
> symbol not found: ap_user_name (/usr/apache/libexec/libphp4.so)
> symbol not found: ap_max_requests_per_child
(/usr/apache/libexec/libphp4.so)
> symbol not found: ap_server_root (/usr/apache/libexec/libphp4.so)
> symbol not found: ap_user_id (/usr/apache/libexec/libphp4.so)
> symbol not found: ap_group_id (/usr/apache/libexec/libphp4.so)
> symbol not found: top_module (/usr/apache/libexec/libphp4.so)
>
> i'm using solaris 8 release 10/01 on sun ultra-450 sparc, apache 1.3.20
with
> openssl 0.9.2b, tried to run php 4.0.6
>
> what can i do? which libraries do i need, where do i have to place them?
> (maybe it's a trivial problem, but i'm almost new with linux, unix and
> sun-machines...)
>
> Walter Karpf
> Vienna, Austria
>
>