Re: libphp4.so--> undefined symbol: uncompress
| From: | Rasmus Lerdorf | Date: | Wed, 12 Dec 2001 21:05:56 +0000 |
| Subject: | Re: libphp4.so--> undefined symbol: uncompress | ||
| References: | 1 | Groups: | php.install |
| Request: | Send a blank email to php-install+get-5284@lists.php.net to get a copy of this message | ||
Try adding --with-zlib to your configure line.
On Wed, 12 Dec 2001, Mark R. wrote:
> Hello all,
>
> I think I may have an easy to fix problem, but I'm stumped as to what needs
> to be done. I downloaded Apache 1.3.22 and PHP 4.1.0 today. Built Apache
> with "./configure --enable-module=so --prefix=/usr/local/apache", and after
> installing Apache, built PHP with
> "./configure --with-mysql=/usr/local/mysql --with-apxs=/usr/local/apache/bin
> /apxs". I've changed httpd.conf as needed, and when I start the server I
> get:
>
> [root@gorf lib]# /usr/local/apache/bin/apachectl start
> Syntax error on line 205 of /usr/local/apache/conf/httpd.conf:
> Cannot load /usr/local/apache/libexec/libphp4.so into server:
> /usr/local/apache/libexec/libphp4.so: undefined symbol: uncompress
> /usr/local/apache/bin/apachectl start: httpd could not be started
>
> Simply because I saw it in some other postings, (not because I know what it
> does :) ), I ran:
>
> [root@gorf libexec]# ldd -r libphp4.so
> libdl.so.2 => /lib/libdl.so.2 (0x4013b000)
> libcrypt.so.1 => /lib/libcrypt.so.1 (0x4013f000)
> libresolv.so.2 => /lib/libresolv.so.2 (0x4016d000)
> libpam.so.0 => /lib/libpam.so.0 (0x4017f000)
> libm.so.6 => /lib/libm.so.6 (0x40187000)
> libnsl.so.1 => /lib/libnsl.so.1 (0x401aa000)
> libc.so.6 => /lib/libc.so.6 (0x401c1000)
> /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x80000000)
> undefined symbol: uncompress (./libphp4.so)
> undefined symbol: compress (./libphp4.so)
> undefined symbol: ap_block_alarms (./libphp4.so)
> undefined symbol: ap_unblock_alarms (./libphp4.so)
> undefined symbol: ap_user_id (./libphp4.so)
> undefined symbol: ap_server_root (./libphp4.so)
> undefined symbol: ap_group_id (./libphp4.so)
>
>
> It goes on and on with the 'undefined symbol' errors. Is this something
> that's missing from /etc/ld.so.conf? I need to add another path? Or
> something more?
>
> Thanks,
> Mark
>
>
>
>
>
>