pg_encoding_to_char error: apache + mod_ssl + php w/ postgresql support

From: Date: Wed, 06 Mar 2002 02:13:28 +0000
Subject: pg_encoding_to_char error: apache + mod_ssl + php w/ postgresql support
Groups: php.install 
Request: Send a blank email to php-install+get-6279@lists.php.net to get a copy of this message
I'm having trouble trying to run mod_ssl + Apache + PHP with Postgresql support. When trying to start Apache, I receive the following error message: Cannot load /usr/local/apache/libexec/libphp4.so into server: /usr/local/apache/libexec/libphp4.so: Undefined symbol "pg_encoding_to_char" When I build Apache with mod_ssl, I'm forced (as far as I know) to load PHP using the apxs, and I get this error. However, when I build Apache without mod_ssl and consequently am able to build PHP into Apache as a static module, then this error disappears. Any ideas? _______________________________________ I'm using the following on FreeBSD 4.4: o apache 1.3.23 o mod_ssl 2.8.7 o php 4.1.1 o openssl 0.9.6c o postgresql 7.2 Here are my configuration options. For mod_ssl: ./configure --with-apache=/usr/local/src/apache_1.3.23 --with-ssl=/usr/local/src/openssl-0.9.6c --prefix=/usr/local/apache --enable-module=ssl --enable-module=most --enable-shared=max --enable-rule=EAPI For php: ./configure --with-pgsql=/usr/local/pgsql --enable-track-vars --enable-calendar --with-apxs=/usr/local/apache/bin/apxs For postgresql and openssl, no custom config options were used.

« previous php.install (#6279) next »