libphp4.so and pthread_getspecific on 4.6-RELEASE FreeBSD
| From: | Bruce Rhodewalt | Date: | Thu, 29 Aug 2002 17:34:35 +0000 |
| Subject: | libphp4.so and pthread_getspecific on 4.6-RELEASE FreeBSD | ||
| Groups: | php.install | ||
| Request: | Send a blank email to php-install+get-8258@lists.php.net to get a copy of this message | ||
Thanks a lot for any suggestions. My problem: Apache works unless I load
PHP, at which point I get this error:
Cannot load /usr/local/apache2/modules/libphp4.so into
server: /usr/local/apache2/modules/libphp4.so: Undefined
symbol "pthread_getspecific"
I worked off these instructions:
http://www.php.net/manual/en/install.apache.php.
I used the default apache
prefix, and --with-apxs2=/my/path/apxs. Also, downloaded and installed
pth-1.4.1 before configuring apache. I didn't change anything in php.ini.
I got php4-latest.tar.gz from snaps.php.net this morning and installed it
over 4.2.2.
hairspray# /usr/local/apache2/bin/httpd -l
Compiled in modules:
core.c
mod_access.c
mod_auth.c
mod_include.c
mod_log_config.c
mod_env.c
mod_setenvif.c
prefork.c
http_core.c
mod_mime.c
mod_status.c
mod_autoindex.c
mod_asis.c
mod_cgi.c
mod_negotiation.c
mod_dir.c
mod_imap.c
mod_actions.c
mod_userdir.c
mod_alias.c
mod_so.c
hairspray# /usr/local/apache2/bin/httpd -V
Server version: Apache/2.0.40
Server built: Aug 28 2002 22:05:55
Server's Module Magic Number: 20020628:0
Architecture: 32-bit
Server compiled with....
-D APACHE_MPM_DIR="server/mpm/prefork"
-D APR_HAS_SENDFILE
-D APR_HAS_MMAP
-D APR_HAVE_IPV6
-D APR_USE_FLOCK_SERIALIZE
-D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
-D APR_HAS_OTHER_CHILD
-D AP_HAVE_RELIABLE_PIPED_LOGS
-D HTTPD_ROOT="/usr/local/apache2"
-D SUEXEC_BIN="/usr/local/apache2/bin/suexec"
-D DEFAULT_PIDLOG="logs/httpd.pid"
-D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
-D DEFAULT_LOCKFILE="logs/accept.lock"
-D DEFAULT_ERRORLOG="logs/error_log"
-D AP_TYPES_CONFIG_FILE="conf/mime.types"
-D SERVER_CONFIG_FILE="conf/httpd.conf"
Thanks again.
Bruce Rhodewalt
bruce@rhodewalt.com