Re: http_cookie_set and http_cookie_remove
| From: | Andreas Treichel | Date: | Sun, 23 Jul 2017 18:13:54 +0000 |
| Subject: | Re: http_cookie_set and http_cookie_remove | ||
| References: | 1 2 3 4 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-100020@lists.php.net to get a copy of this message | ||
Hi Michał,
As an average developer, I see providing new functions with http_ prefix more meaningful and their API more simple because of fewer parameters I need to pass.
Although however, I see the naming convention you've used is rarely used. Looking in the docs, there are few other HTTP sapi related functions which don't follow that convention, like: header() - Send a raw HTTP header header_remove() - Remove previously set headers header_register_callback() - Call a header function headers_sent() - Checks if or where headers have been sent - this function http_response_code() - Get or Set the HTTP response code - which is THE ONLY ONE function prefixed this wayThis might be one of my next RFCs if my first RFC is well received.