Re: [RFC] Improve openssl_random_pseudo_bytes()
| From: | Sammy Kaye Powers | Date: | Sat, 20 Oct 2018 13:01:13 +0000 |
| Subject: | Re: [RFC] Improve openssl_random_pseudo_bytes() | ||
| References: | 1 2 3 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-103349@lists.php.net to get a copy of this message | ||
On Fri, Oct 19, 2018 at 10:21 PM Sara Golemon <pollita@php.net> wrote:
>
> On Fri, Oct 19, 2018 at 9:20 PM Sara Golemon <pollita@php.net> wrote:
> > On Fri, Oct 19, 2018 at 3:47 PM Sammy Kaye Powers <me@sammyk.me> wrote:
> > > I'd like to start a discussion on the "Improve
> > > openssl_random_pseudo_bytes()" RFC:
> > >
> > > https://wiki.php.net/rfc/improve-openssl-random-pseudo-bytes
> > >
> > lgtm; though a small nit: s/RETURN_BOOL(pzv, 1)/RETURN_TRUE(pzv)/g
> > Slightly more readable that way.
> >
> Or rather: ZVAL_BOOL(pzv, 1) => ZVAL_TRUE(pzv)
Good call - done! :)