Re: Variadic is_*() functions
| From: | Sara Golemon | Date: | Tue, 12 Feb 2019 15:55:14 +0000 |
| Subject: | Re: Variadic is_*() functions | ||
| References: | 1 2 3 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-104364@lists.php.net to get a copy of this message | ||
On Tue, Feb 12, 2019 at 4:30 AM Côme Chilliet <come@opensides.be> wrote:
> My first thought was that this must already exists under another name,
> but it seems that none of array_map, array_walk or array_reduce allows to
do that easily.
> (That is, in a more readable way than the boolean operator string,
otherwise it’s useless)
>
Not in core, but I and I'm sure others, have built that pattern more than
once.
Ref: https://github.com/phplang/generator/blob/master/src/iterable.php
-Sara