Re: [RFC] Desire to move RFC add_str_begin_and_end_functions to a vote
| From: | Dik Takken | Date: | Sat, 29 Jun 2019 20:36:31 +0000 |
| Subject: | Re: [RFC] Desire to move RFC add_str_begin_and_end_functions to a vote | ||
| References: | 1 2 3 4 5 6 7 8 9 10 11 12 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-106114@lists.php.net to get a copy of this message | ||
On 29-06-19 17:53, will@wkhudgins.info wrote:
> How do people tend to feel about the "str_startswith" vs
> "str_starts_with" naming convention? I've seen people propose both.
For best readability one should write '_' between separate words, just
like a space would be used in regular text, IHMO. The PHP standard
library already has a number of methods that are named that way, like
str_word_count(). So, I would favor to have str_starts_with().
Regards,
Dik Takken