Re: [RFC]

From: Date: Sat, 15 Feb 2020 23:19:50 +0000
Subject: Re: [RFC]
References: 1 2  Groups: php.internals 
Request: Send a blank email to internals+get-108610@lists.php.net to get a copy of this message
On 11-02-2020 16:27, Levi Morrison via internals wrote: > I have three immediate thoughts: > > 1. It should be fn or function; > reserving a new word even if it's > contextual is pointless here. Note that even though these do not introduce a new keyword it does mean that either of these would need to become reserved class constant names just like 'class'. Otherwise foo::fn or foo::function is ambiguous when both a function and a class named 'foo' are in scope. Regards, Dik Takken

« previous php.internals (#108610) next »