Re: [RFC] get_debug_type
| From: | Mike Schinkel | Date: | Mon, 17 Feb 2020 22:48:51 +0000 |
| Subject: | Re: [RFC] get_debug_type | ||
| References: | 1 2 3 4 5 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-108651@lists.php.net to get a copy of this message | ||
> On Feb 17, 2020, at 6:42 AM, Kalle Sommer Nielsen <kalle@php.net> wrote:
>
> Den man. 17. feb. 2020 kl. 01.25 skrev Mike Schinkel <mike@newclarity.net>:
>> Though still not exactly sure where you are headed with it since there are few detailed and
>> no code examples the first name that comes to mind for me would be get_real_type().
>
> "real" is a type in PHP (tho we are phasing that out, see is_real()
> and the (real)-cast), so that name would most likely make it more
> confusing to userland.
Certainly.
I picked "real" because of realpath(), but that was just the first thing that came to
mind.
My intent was to propose using a name describing function vs. envisioned use-case, and others have
made good naming suggestions.
-Mike