Re: Re: Changing the generated name for anon classes
| From: | Niklas Keller | Date: | Wed, 04 Mar 2020 20:19:29 +0000 |
| Subject: | Re: Re: Changing the generated name for anon classes | ||
| References: | 1 2 3 4 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-108855@lists.php.net to get a copy of this message | ||
Hi Nikita,
while we're changing the naming scheme, could we also get rid of the
NUL byte, please? Binary in logs due to things like get_class really
isn't that nice.
Regarding checking whether something is an anonymous class, how about
adding a function to check whether a class name is an anonymous class?
Something like is_anonymous_class(get_class($obj));
Best,
Niklas