Re: [RFC] [DISCUSSION] Compact Object Property Assignment
| From: | Levi Morrison via internals | Date: | Mon, 30 Mar 2020 01:06:03 +0000 |
| Subject: | Re: [RFC] [DISCUSSION] Compact Object Property Assignment | ||
| References: | 1 2 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-109442@lists.php.net to get a copy of this message | ||
The current RFC text is not consistent with using
= or => for the
assignments. The assignment = is vastly more common, though, and I
don't understand why if we are using an array syntax we aren't using
=>.
I intend to vote no. I agree that we need to do something in this
space, but this is not it. I don't want perfect to be the enemy of
good either, but I think this still needs more work. Maybe interested
parties (including me) can collaborate off-list somewhere?