Re: [RFC][DISCUSSION] Change var_export() array syntax to use short hand arrays
| From: | Aimeos | Norbert Sendetzky | Date: | Mon, 30 Mar 2020 14:53:09 +0000 |
| Subject: | Re: [RFC][DISCUSSION] Change var_export() array syntax to use short hand arrays | ||
| References: | 1 2 3 4 5 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-109455@lists.php.net to get a copy of this message | ||
Am 30.03.20 um 16:39 schrieb Sara Golemon:
>> I don't see a reason not to follow with the short array syntax; the only
>>> expectation of people using var_export(), AFAIK, is to get valid PHP code;
>>> they don't care about the syntax,
>>
> If "they" don't care about syntax, then why do you?
The output is much easier to read and less cluttered if you do debugging
and thus I support Benjamin's proposal.
Norbert