Re: opcache.jit directive should be split up
| From: | tyson andre | Date: | Sun, 03 May 2020 15:25:36 +0000 |
| Subject: | Re: opcache.jit directive should be split up | ||
| References: | 1 2 3 4 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-109978@lists.php.net to get a copy of this message | ||
Hi CHU Zhaowei,
By alias, I meant "an **alternative** name or label that refers to an item, and can be used to
locate or access it."
(add a way to set the option without removing existing ways)
(Users would have the choice of using both the magic numbers or the strings to refer to the same
setting value).
> E.g. what does "minimal" mean in this context?
It's a short label based on the description of the value in https://wiki.php.net/rfc/jit#phpini_defaults
> 1 - **minimal** JIT (call standard VM handlers)
It would be easier for someone to remember/infer what opcache.jit_optimization_level=minimal
means than 1 if they saw it in their php.ini or a command line invocation,
with or without familiarity with the JIT.
(without needing to go to php.net)
Regards,
- Tyson