Re: PR #5251 adds support for CMS (RFC5662)

From: Date: Mon, 11 May 2020 10:45:14 +0000
Subject: Re: PR #5251 adds support for CMS (RFC5662)
References: 1  Groups: php.internals 
Request: Send a blank email to internals+get-110130@lists.php.net to get a copy of this message
On 11.05.2020 at 11:59, Eliot Lear wrote: > Hi everyone, > > I am new to the PHP development process, so please forgive me if I have > this wrong. > > In PR #5251[1] I’ve created OpenSSL CMS functions that are nearly direct > analogues to the openssl PKCS#7 functions.  Cryptographic Message Syntax > is defined in RFC 5652[2], and is a follow-on to PKCS#7.  These > functions are useful to developers who are creating or verifying > PKI-based signatures (this is the case for me or anyone else who is > implementing or deploying RFC 8520[3]), and there are other IoT services > that are using CMS as well (not to mention certain modern mailing systems). > > There are one or two changes- one can specify the encoding format as an > argument, for instance, and error out out the use of DETACHED with > S/MIME encoding, as nobody seems to know what that would mean. > > I’ve been working with Jakub and others who have been very generous with > their time on code reviews.  I would be grateful for any additional > feedback you would have, with an eye toward merging this PR.  The PR is > already marked as RFC I have not yet formalized that.(*) > > Best regards, > > Eliot > > (*) I tried adding an RFC page on the wiki, but sensibly, as I just > created the account, the system did not permit me to do so. > > [1] https://github.com/php/php-src/pull/5251 > [2] https://www.rfc-editor.org/rfc/rfc5652.html > [3] https://www.rfc-editor.org/rfc/rfc8520.html Thanks for working on CMS support! I have granted you RFC karma. Best of luck with the RFC. :) -- Christoph M. Becker

« previous php.internals (#110130) next »