Re: [RFC] Global functions any() and all() on iterables

From: Date: Tue, 01 Sep 2020 07:59:24 +0000
Subject: Re: [RFC] Global functions any() and all() on iterables
References: 1 2  Groups: php.internals 
Request: Send a blank email to internals+get-111762@lists.php.net to get a copy of this message
On Tue, Sep 1, 2020, 09:31 Nikita Popov <nikita.ppv@gmail.com> wrote: > > To be in line with naming conventions, I would suggest calling these > iter_any() and iter_all(), using iter_* as the prefix for our future > additions to the "functions that work on arbitrary iterables" space. > iterable_any() and iterable_all() would work as well, though are > unnecessarily verbose. > > Regards, > Nikita > Oof, does it really have to be butchered this way? Or are you trolling? 😬 Did the namespaces ship sail forever? Can we just have those instead, please? >

« previous php.internals (#111762) next »