Re: Pass file handle in XMLReader
| From: | Aimeos | Norbert Sendetzky | Date: | Fri, 04 Dec 2020 12:35:51 +0000 |
| Subject: | Re: Pass file handle in XMLReader | ||
| References: | 1 2 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-112413@lists.php.net to get a copy of this message | ||
Am 04.12.20 um 13:23 schrieb Christoph M. Becker:
> For clarity, it might be preferable to introduce a new static creation
> method for this. The implementation could probably use
> xmlReaderForIO()[1], instead of xmlReaderForFile().
Wouldn't xmlReaderForFd() be more suitable or is this only for file
handles, not for streams?
What would be a good name for the new method? XMLReader::stream()?
Best,
Norbert