Re: Proposal: short_var_export($value, bool $return=false, int $flags=0)
| From: | Rowan Tommins | Date: | Thu, 21 Jan 2021 09:03:05 +0000 |
| Subject: | Re: Proposal: short_var_export($value, bool $return=false, int $flags=0) | ||
| References: | 1 2 3 4 5 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-112952@lists.php.net to get a copy of this message | ||
On 20 January 2021 23:19:21 GMT, Sara Golemon <pollita@php.net> wrote:
>IMO print_r/var_dump should be kept out of this discussion. Those are
>human
>readable outputs for human consumption. var_export() is about a
>machine
>readable output for recreating initial state within a runtime. The
>requirements presented are wholly different.
In that case, why are we spending so much time discussing how to make it look nicer for human
consumption?
Of the changes proposed, I think only the leading backslash on class names actually makes a
difference to machine readability, and that could probably just be changed and documented as fixing
the existing functionality.
What are the requirements of var_dump that *couldn't* be merged with var_export?
Regards,
--
Rowan Tommins
[IMSoP]