Re: [RFC] Name issue - is_literal/is_trusted
| From: | Derick Rethans | Date: | Tue, 22 Jun 2021 19:50:45 +0000 |
| Subject: | Re: [RFC] Name issue - is_literal/is_trusted | ||
| References: | 1 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-115042@lists.php.net to get a copy of this message | ||
On 22 June 2021 19:11:05 BST, Craig Francis <craig@craigfrancis.co.uk> wrote:
>Hi Internals,
>
>As the name
is_trusted() seems to be causing contention, I think
>more
>than the alternative option would. Since we want to get this right, and
>we
>still have time before the feature freeze, this might be worth
>re-looking
>at. Particularly if you are one of those unsure about it, read on.
Just changing the name to something not misleading isn't going to change my opinion about
voting for this. It's grown into a concoction of different things than the original is_literal,
that just checks a single string for its literalness.
cheers,
Derick