Re: Introduce str_left/right In 8.1

From: Date: Thu, 24 Jun 2021 12:08:15 +0000
Subject: Re: Introduce str_left/right In 8.1
References: 1 2 3 4 5 6 7  Groups: php.internals 
Request: Send a blank email to internals+get-115116@lists.php.net to get a copy of this message
> I can also imagine bikeshed... This is what can be discussed apart from whether these function come to PHP. I am waiting for the other voices; there is surely someone that can come up with a more creative name, a name that is short yet descriptive. > str_left_part/str_right_part is just what came to mind, I thank you, Andreas, for suggesting new names. You are right that substr can give surprising results. Str_starts_with and ends_with return bool, not strings. So, we do have need of these functions. Best

« previous php.internals (#115116) next »