Re: RFC: Add `final class Vector` to PHP

From: Date: Fri, 17 Sep 2021 08:06:47 +0000
Subject: Re: RFC: Add `final class Vector` to PHP
References: 1  Groups: php.internals 
Request: Send a blank email to internals+get-116059@lists.php.net to get a copy of this message
Am 17.09.2021 um 04:09 schrieb tyson andre <tysonandre775@hotmail.com>: > I've created a new RFC https://wiki.php.net/rfc/vector > proposing to add final class Vector to PHP. First of all: I don't have a strong opinion on a Vector class being useful or necessary. But I have two comments about this RFC: 1) Using the very generic name Vector without any prefix/namespace seems dangerous and asking for BC breaks. 2) I don't like that this class is final. The reasons given in https://wiki.php.net/rfc/vector#final_class <https://wiki.php.net/rfc/vector#final_class> seem unconvincing to me and restrict the usage of Vector in a way which makes me question the usefulness to a big enough part of the PHP community. These two reasons combined would make me reject the RFC at the current stage. - Chris

« previous php.internals (#116059) next »