Re: RFC Concept: "Import" of simplied string man ipulation and other instructions from ASP Classic
| From: | Daniele B via internals | Date: | Sat, 25 Sep 2021 21:22:51 +0000 |
| Subject: | Re: RFC Concept: "Import" of simplied string man ipulation and other instructions from ASP Classic | ||
| References: | 1 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-116170@lists.php.net to get a copy of this message | ||
Rowan, I did the bithday party of my two years old daughter yesterday.. if I knew before I wrote you
about this topic a couple of days ago to invite you all to the party.. ; ) I'm not here
exacly to meet up you my github account..I also invested a good half of day about this
*simplification* topic.. sorry.About the "magic" tilde is nothing else an help to not
break in the 0 position, about the rest of your comments are merely about your aesthetic tast that
probably is different from mine..What's that? I need to call for web developers who consume
php?Well, I was thinking to PHP like a software project..
Daniele Boninihttp://github.com/par7133
----- Original message -----From:
rowan+dot+collins+at+gmail+dot+comDate: Sat, 25 Sep 2021 20:55:02 +0000Subject: Re: RFC
Concept: "Import" of simplied string man ipulation and other instructions from ASP Classic
On 25 September 2021 21:17:22 BST, Daniele B <my25mb@aol.com> wrote:
>Hi Rowan,
>Unfortunately I can't post all the code here by the mailing list cause the message size
>limit.
Well, that's easily solved: put it online, as a github gist, a blog post, wherever you like,
and link to that.
However, much better than the code would be one-line summaries of what these functions are *for*.
Your code for str_place leaves me more confused than before: What's the magic tilde for?
What's the other magic value in the else clause? And why is it called "place"?
Similar questions arise for a lot of the other functions you mention. I suspect the problem is that
you've been using them for years, so they feel obvious to you. You need to step back, imagine
you'd never heard of them before, and explain why *those particular functions*, of the millions
of possible helpers, should be added to PHP.
Regards,
--
Rowan Tommins
[IMSoP]