Re: RFC [Discussion] array_column results grouping

From: Date: Mon, 06 Dec 2021 08:44:51 +0000
Subject: Re: RFC [Discussion] array_column results grouping
References: 1 2 3 4  Groups: php.internals 
Request: Send a blank email to internals+get-116572@lists.php.net to get a copy of this message
Hello Folks, Thanks a lot for your feedback, as already mentioned in the RFC and as mentioned by Rowan too a new function is an option. I think that mostly we will go with the new function option. I will try to edit the PR to add a new function, does there any suggestions/naming conventions for the new function? a colleague suggested being array_group_by and Hendra already suggested to be array_column_group which is good too. Regards, Hassan On Sun, Dec 5, 2021 at 4:02 PM Rowan Tommins <rowan.collins@gmail.com> wrote: > > On 05/12/2021 10:41, Mark Randall wrote: > > On 04/12/2021 14:21, Marco Pivetta wrote: > >> Gonna vote no on this: please design new/dedicated > >> functions, > >> rather than > >> expanding optional parameters. > > > > > > I would vote no for the same reason. > > > Since this is explicitly an open question in the current RFC draft, it > seems a bit premature to talk about voting, rather than encouraging the > RFC to develop in a particular direction. > > For what it's worth, I agree that a new function is probably better > here, because the argument list of array_column is already quite > complicated. A new function also leaves the way open to add more > functionality, such as the "reducer" callback suggested by Hendra > Gunawan; I don't think that's needed in the first implementation, though. > > In general, I like the proposal - like array_column itself, it's one of > those things that's fairly _simple_ to do in userland, but also fairly > _often_ done, so compacting it to a neat function call seems useful. > > Regards, > > -- > Rowan Tommins > [IMSoP] > > -- > PHP Internals - PHP Runtime Development Mailing List > To unsubscribe, visit: https://www.php.net/unsub.php >

« previous php.internals (#116572) next »