Re: [RFC][Under discussion] Fetch properties in const expressions
| From: | Alexandru Pătrănescu | Date: | Sun, 29 May 2022 18:41:39 +0000 |
| Subject: | Re: [RFC][Under discussion] Fetch properties in const expressions | ||
| References: | 1 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-117828@lists.php.net to get a copy of this message | ||
On Sat, May 28, 2022 at 12:44 PM Ilija Tovilo <tovilo.ilija@gmail.com>
wrote:
> Hi everyone
>
> I'd like to start a discussion on a simple RFC to allow fetching
> properties in constant expressions.
> https://wiki.php.net/rfc/fetch_property_in_const_expressions
>
> The RFC proposes adding support for fetching properties in constant
> expressions using the -> operator. I'm looking forward to your
> feedback.
>
I feel that the RFC should be named "Fetch properties in initializers", in
sync with https://wiki.php.net/rfc/new_in_initializers
You explain what "constant expression" means but I feel that using
"initialize expression" would be more clear.
From what I understand, "constant expression" is named like this because
until PHP 8.1 it really was a constant.
And of course because internally this is how the functions in code are
named:
- zend_is_allowed_in_const_expr
- zend_compile_const_expr
- zend_const_expr_to_zval
It's unclear how easy it would be to rename them to init_expr instead of
const_expr
but it might be worth it if we consider that "initialize expression" is a
better name.
The RFC looks great and clear.
Regards,
Alex
>
> Regards,
> Ilija
>
> --
> PHP Internals - PHP Runtime Development Mailing List
> To unsubscribe, visit: https://www.php.net/unsub.php
>
>