Re: [RFC] [Under Discussion] Random Extension Improvement
| From: | Go Kudo | Date: | Mon, 20 Jun 2022 16:03:42 +0000 |
| Subject: | Re: [RFC] [Under Discussion] Random Extension Improvement | ||
| References: | 1 2 3 4 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-118020@lists.php.net to get a copy of this message | ||
2022年6月21日(火) 0:42 Tim Düsterhus <tim@bastelstu.be>:
> Hi
>
> On 6/20/22 17:12, Go Kudo wrote:
> >> CombinedLCG
> >
> > This is provided as an OOP implementation for the
> >
lcg_value() function,
> > but I don't actually
> > want it to be used anymore, so I probably shouldn't provide a class for
> it.
> >
> > And to begin with, the current CombinedLCG cannot even be seeded with
> > arbitrary values.
> >
> > However, I think it needs to remain in the internal API either way. (The
> > option of not providing
> > it to userland is a valid one.)
>
> I wouldn't object to dropping CombinedLCG, especially since its internal
> parameters are not defined via the name (contrary to MT19937).
>
> > What do you think about the Random\CryptoSecureEngine
> > interface?
> > It is just a marker interface with no methods.
> >
> > However, I currently think it is better than adding a method like
> > isSecure(): bool
> > to the Random\Engine.
> >
>
> I *much* prefer the marker interface.
>
> Best regards
> Tim Düsterhus
>
Hi
Added option to discontinue CombinedLCG.
https://wiki.php.net/rfc/random_extension_improvement
I am struggling with the following issue:
1. change `Randomizer::pickArrayKey(array $array, int $num =1):
int|string|array`
to Randomizer::pickArrayKeys(array $array, in $num): array.
2. Change the class name to "Always PascalCase" or "PascalCase except
Acronyms".
I hope I can solve the discussion by e-mail, but if I can't, I will further
add it to the RFC options.
Best regards,
Go Kudo