Re: [RFC] [Discussion] Deprecate functions with overloaded signatures
| From: | Tim Düsterhus | Date: | Fri, 05 May 2023 19:59:40 +0000 |
| Subject: | Re: [RFC] [Discussion] Deprecate functions with overloaded signatures | ||
| References: | 1 2 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-120199@lists.php.net to get a copy of this message | ||
Hi
On 5/5/23 18:12, Derick Rethans wrote:
createFromIso8601(string $specification, int $options = 0) -> createFromISO8601String I am open to bike shedding about this :-)Okay, I'd like a different color of my bikeshed: Please no consecutive uppercase letters in the function name. I find createFromIso8601 (or createFromIso8601String if find the 'String' suffix useful) much more readable than createFromISO8601String. Uppercase acronyms are especially bad if followed by another ucfirst word, because the word boundary is not immediately visible there. Not the case here (it's digits), but still bad. Best regards Tim Düsterhus