Re: [RFC] Improve language coherence for the behaviour of offsets and containers
| From: | Levi Morrison | Date: | Wed, 10 Jul 2024 15:22:30 +0000 |
| Subject: | Re: [RFC] Improve language coherence for the behaviour of offsets and containers | ||
| References: | 1 2 3 4 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-124351@lists.php.net to get a copy of this message | ||
> Everything considered, I still do not think changing the name of the append() method is a good
> idea, will it hurt adoption in the short term for some classes, yes, but I prefer this than having a
> large part of the ecosystem needing to create an alias just for some weird cases.
I don't fully understand the issue with aliases. Could you elaborate
on that? Would calling the method instead of direct aliasing avoid
whatever the issue is?