Re: Re: [RFC] [Discussion] Fix up BCMath Number Class / Change GMP bool cast behavior

From: Date: Thu, 11 Jul 2024 13:26:25 +0000
Subject: Re: Re: [RFC] [Discussion] Fix up BCMath Number Class / Change GMP bool cast behavior
References: 1 2  Groups: php.internals 
Request: Send a blank email to internals+get-124386@lists.php.net to get a copy of this message
On Wednesday, 10 July 2024 at 07:35, Saki Takamachi <saki@sakiot.com> wrote: > Added one more change to the RFC. > > Currently, there is no other expression for comparison in PHP called "comp”. The > expression "cmp" is mainly used for functions, and the expression "compare" is > used for class methods. > > e.g. > https://www.php.net/manual/ja/splpriorityqueue.compare.php > https://www.php.net/manual/ja/collator.compare.php > > Therefore, follow these conventions and rename comp() to > compare(). Thank you, I am happy will all the provided amendments now! Best regards, Gina P. Banyard

« previous php.internals (#124386) next »