Re: function autoloading v4 RFC
| From: | Mel Dafert | Date: | Mon, 19 Aug 2024 18:28:09 +0000 |
| Subject: | Re: function autoloading v4 RFC | ||
| References: | 1 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-125051@lists.php.net to get a copy of this message | ||
On August 15, 2024 5:22:51 PM GMT+02:00, Rob Landers <rob@bottled.codes> wrote:
>Hello internals,
>
>I've decided to attempt an RFC for function autoloading. After reading hundreds of ancient
>(and recent) emails relating to the topic along with several abandoned RFCs from the past, and after
>much review, I've decided to put forth a variation of a previous RFC, as it seemed the least
>ambitious and the most likely to work:
>
>https://wiki.php.net/rfc/function_autoloading4
>
>Please let me know what you think. An implementation should be along before opening it for a
>vote (now that I realize how important that is).
>
>— Rob
Hello,
I've also noted that on another RFC, but I think it applies here too:
Any new constants that are shaped like an enum and used like an enum should just be
an actual enum. I think instead of
SPL_AUTOLOAD_CLASS and
SPL_AUTOLOAD_FUNCTION,
there should be an enum AutoloadType (to be bikeshed), and the new parameters
should be typed as such, instead of int.
Regards,
Mel