Re: [RFC] Create "split" as an alias to "explode"
| From: | Daikaras | Date: | Tue, 19 Aug 2025 06:37:08 +0000 |
| Subject: | Re: [RFC] Create "split" as an alias to "explode" | ||
| References: | 1 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-128504@lists.php.net to get a copy of this message | ||
On 8/18/2025 5:57 PM, Vinicius Dias wrote:
Hello, folks. As discussed in previous messages [1], I am proposing the creation of an alias function-1. My 2c is that aliases should be deprecated and eventually removed, not more added. Modern PHP projects tend to have coding standards that prohibit the use of aliases. Seesplitto theexplodefunction. Here is the RFC for discussion: https://wiki.php.net/rfc/create-split-alias-to-explode [1] https://news-web.php.net/php.internals/128477
no_alias_functions PHP CS Fixer rule for example. The existence of aliases only creates unnecessary noise across the ecosystem, eg CI failing when someone does end up using the alias. If you think that a function should be named this or that, you can always create aliases in userland code.