Re: _FILE_OFFSET_BITS=64 considered harmful

From: Date: Fri, 22 Oct 2004 12:26:50 +0000
Subject: Re: _FILE_OFFSET_BITS=64 considered harmful
References: 1 2 3  Groups: php.internals 
Request: Send a blank email to internals+get-13453@lists.php.net to get a copy of this message
On Friday 22 October 2004 13:33, Joe Orton wrote: > On Fri, Oct 22, 2004 at 12:59:04PM +0200, Edin Kadribasic wrote: > > However I consider crashing apache children with signal 25 when doing > > simple is_file() or fopen() on large files really harmful. Apache flat > > out refuses to start if you have enabled php error log and that file > > happen to be 2GB or bigger. > > For Linux at least that was fixed since 2.0.50, or are you using 1.3 > still? I still use 1.3 (like, I guess, most of the PHP installations outthere). > w.r.t is_file() or open(), can you give more details? open() on a >2Gb > file will give EFBIG not die with SIGXFSZ. *writing* beyond 2Gb will > die with SIGXFSZ, yes, is that what you mean? I had a patch to make > sure SIGXFSZ was ignored but didn't bother with it since the large > logfile stuff went in which solves the common problem. Yes, fwrite() will die with SIGXFSZ. is_file() file_exists() and friends will fail returning bugus results. A number of bug reports mention these issues. Just a quick google search gave me #15260 #27765 #24411 #27792. Edin

« previous php.internals (#13453) next »