Re: Re: streams file uri under windows
| From: | Rob Richards | Date: | Wed, 27 Oct 2004 11:26:37 +0000 |
| Subject: | Re: Re: streams file uri under windows | ||
| References: | 1 2 3 4 5 6 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-13561@lists.php.net to get a copy of this message | ||
From: Alan Knowles
> you could follow the nautilus standard for this and use
> smb://hostname/sharename/file.txt ?
Can't do that as this is stemming from an issue with libxml. It uses the
file:/// syntax when needed. Currently with the change in streams, it fails
the check as it is now deemed to be a remote host. This causes the libxml
I/O handler to fall back to its internal file handling which I would
eventually like to diasable all libxml I/O and not allow it to fallback on
anything if it cant match a php stream handler.
That being said, imo either the check should be tightened up a bit (for all
platforms) or just removed and let it issue whatever error it currently does
if it cant open the stream.
using file://localhost/localpath will fail on all platforms - though it
perfectly legal.
file:/// will fail just on windows due to the current check, but on other
platforms will allow anything after it.
If I make that proposed change, it will allow file:/// but since you can
place any path after that (local or remote) and it works, it makes the check
a little pointless.
I have no problem adding my change in there, but it seems that it just adds
to the wtf factor since if you then use the file:/// syntax, you are free to
use any path you want to bypass the remote host check.
Rob