Re: cvs: php-src / NEWS /ext/standard basic_functions.c basic_functions.h
| From: | Ilia Alshanetsky | Date: | Sun, 10 Apr 2005 16:54:16 +0000 |
| Subject: | Re: cvs: php-src / NEWS /ext/standard basic_functions.c basic_functions.h | ||
| References: | 1 2 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-15940@lists.php.net to get a copy of this message | ||
Andrey Hristov wrote:
Because both functions are in HEAD and still the API is not released I would appreciate if time_nanosleep() is renamed to nanosleep(). time_sleep_until() "emulate" a system function but uses it and in this case maybe the name may stay the same. To rephrase, if there are no objections I will go and rename time_nanosleep() to nanosleep() :)I'd prefer the function remain called time_nanosleep(), while there is certainly a value to having C -> PHP mappings have the same name. The direction we seem to be taking lately is towards "namespacing" similar functions together. Ilia