Re: Re: cvs: php-src /ext/spl php_spl.c

From: Date: Thu, 14 Apr 2005 21:06:52 +0000
Subject: Re: Re: cvs: php-src /ext/spl php_spl.c
References: 1 2 3 4 5 6  Groups: php.internals 
Request: Send a blank email to internals+get-15964@lists.php.net to get a copy of this message
Hello Michael, Thursday, April 14, 2005, 5:12:03 PM, you wrote: > Hi Marcus Boerger, you wrote: >> Hello Andi, >> >> Monday, April 11, 2005, 12:35:34 AM, you wrote: >> >> >>>Hi, >> >> >>>Andrey might have a point. Unlike the other names you've defined, this one >>>feels as if it'll break lots of apps. >>>How about FileIterator? >> >> >> very missleading. Maybe FileObject or FileInstance or whatever to habe >> something longer but then again many scripts will fail for the same reason. >> And i tempt to think many people implementing such a class might have >> avoided the name 'File' to differentiate from function 'File' (which is >> one of the reasons i chose the short name). > It will definitly break lots of PEAR and PEAR-dependant code, too. Renamed it to FileObject, see: http://www.php.net/~helly/php/ext/spl/classFileObject.html Best regards, Marcus

« previous php.internals (#15964) next »