RE: [PATCH] Ingres error reporting functions

From: Date: Tue, 19 Apr 2005 15:02:32 +0000
Subject: RE: [PATCH] Ingres error reporting functions
Groups: php.internals 
Request: Send a blank email to internals+get-16034@lists.php.net to get a copy of this message
Ok, As you say there does not seem to be any consistent naming of functions. A fact I guess PDO will address. I have changed the names to match mysql and have a 3rd function (ingres_errsqlstate) that reports the SQLSTATE of the last statement run. With Ingres SQLSTATE and errno is not the same thing since errno is more granular than SQLSTATE. The revised code can be found in this link: http://www.ingres.co.uk/php/head/ingres_error_reporting_rev2.diff thanks grant > -----Original Message----- > From: Lukas Smith [mailto:lsmith@php.net] > Sent: 19 April 2005 16:25 > To: Croker, Grant > Cc: internals@lists.php.net > Subject: Re: [PATCH] Ingres error reporting functions > > Grant Croker wrote: > > > I would like to submit the following patch to PHP: > > > > http://www.ingres.co.uk/php/head/ingres_error_reporting.diff > > > > It includes 3 new functions for reporting errors; ingres_error(), > > ingres_error_text() and ingres_error_sqlstate(). Also included is the > > ability to suppress E_WARNING messages that happen when a database error > > is detected. This requires the following to be added to php.ini under > > the section titled "[Ingres II]": > > I know its too late to fix this in the current database extensions (who > all follow either the native, the mysql ext or some random naming the > given developer came up with), but you might want to atleast try and > follow an existing database extension with the function naming. I guess > ext/mysql or mysqli might be a good rolemodel just because its used alot. > > regards, > Lukas >

« previous php.internals (#16034) next »