Re: wishlist item for 6.0.0
| From: | Jani Taskinen | Date: | Thu, 06 Oct 2005 09:19:50 +0000 |
| Subject: | Re: wishlist item for 6.0.0 | ||
| References: | 1 2 3 4 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-19432@lists.php.net to get a copy of this message | ||
On Thu, 6 Oct 2005, Stanislav Malyshev wrote:
HH>>So i'm all for keeping the $this-> prefix even though it adds some HH>>extra typing ... Just a thought - we could have compromise solution, i.e. some syntax sugar to mean $this->foo - for example $.foo or something like that. This way we have clear visual difference between locals and properties and at the same time save a lot of $this-> typing. Of course, the downside is that you coudl type $. accidentally :)
And make the scripts even harder to read? No thanks.
$this->is_fine.
--Jani