Re: Fixing this date mess
| From: | Pierre | Date: | Fri, 25 Nov 2005 08:28:32 +0000 |
| Subject: | Re: Fixing this date mess | ||
| References: | 1 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-20343@lists.php.net to get a copy of this message | ||
On Fri, 25 Nov 2005 00:21:17 -0800
rasmus@lerdorf.com (Rasmus Lerdorf) wrote:
> We need to fix this date thing along with the Digest Auth mixup and
> get a 5.1.1 out the door soon. I see Ilia committed a fix for the
> Digest Auth thing, so assuming that this fix works, we just need to
> figure out what to do with this date class. We can either roll back:
>
>
> http://cvs.php.net/diff.php/php-src/ext/date/php_date.c?r1=1.43.2.20&r2=1.43.2.21&ty=u
>
> or perhaps a better option is to rename that internal class for now
> until we have a better idea of what this class is going to look like
> and how we transition pear/Date users. Naming it date_ex (for
> experimental) or something like that for now lets us keep the class
> constants as they are and hopefully Derick and Pierre can come to
> some sort of truce on the actual implementation. I don't think
> having this mostly empty date class placeholder helps anybody right
> now.
Put it back into the #ifdef.
> This rename would also give us a migration path where you could have
> a simple: class date extends date_ex { ... } wrapper which could then
> be removed when we have the final internal date class implementation.
I' opposed to add a class now in 5.1, even with a rename, we better to
do what I explained you again this morning:
- Keep 5.x as it was, only the underlying code has been replaced
- take the time to define, implement, document and test a new date/time
API in php6, we can even do that in pecl and put it in php-src at a
later point
--Pierre