Re: E_ALL changes in 5.2/6.0
| From: | Ilia Alshanetsky | Date: | Mon, 15 May 2006 13:23:18 +0000 |
| Subject: | Re: E_ALL changes in 5.2/6.0 | ||
| References: | 1 2 3 4 5 | Groups: | php.internals |
| Request: | Send a blank email to internals+get-23366@lists.php.net to get a copy of this message | ||
I suggest that we add E_STRICT now, but not include E_STRICT into E_ALL, so people who are not using E_STRICT error reporting level don't have their applications start spewing strict messages.
We cannot force people to change their code, all we can reasonably do is provide notification mechanism, for those who do.
On 15-May-06, at 9:16 AM, Derick Rethans wrote:
On Mon, 15 May 2006, Ilia Alshanetsky wrote:Ilia Alshanetsky Advanced Internet Designs Inc. ilia@prohost.orgMy opinion is that if we intend to make something stop working (give fatal error) in future releases we need to provide some form of notice be it E_STRICT or E_NOTICE to our users now, so they can anticipate the change. As far as inclusion of E_STRICT into E_ALL, I think this is a good idea, but is probably premature for the 5.2 release.Then when do you suggest we add it (before 6.0)? regards, Derick