Re: Re: strlen() under unicode.semantics

From: Date: Fri, 23 Jun 2006 07:01:21 +0000
Subject: Re: Re: strlen() under unicode.semantics
References: 1 2  Groups: php.internals 
Request: Send a blank email to internals+get-24193@lists.php.net to get a copy of this message
Hi, in my opinion that name is bad since most of the time the string won't be stored using the internal encoding but stored using some implicit converted encoding like the encoding of the stream being used or the one from the database. So the size needed to store the string would most likley be different than the one returned by str_storage_size(). johannes On Friday 23 June 2006 08:07, Andrei Zmievski wrote: > How about str_storage_size()? It is explicit enough that people will > be wary of using it. > > -Andrei > > On Jun 22, 2006, at 10:56 PM, Andi Gutmans wrote: > > Oops, senile me :) > > > > How about str_size()?

« previous php.internals (#24193) next »