Re: Tests - and a question

From: Date: Tue, 15 May 2007 08:44:59 +0000
Subject: Re: Tests - and a question
References: 1 2 3 4 5  Groups: php.internals 
Request: Send a blank email to internals+get-29431@lists.php.net to get a copy of this message
Antony Dovgal wrote:
On 05/15/2007 11:52 AM, SoftVirus wrote:
Hello Zoe, Marcus & Tony, Files names having _(basic|variation|error|object).phpt looks much better. File names _[0-9]*.phpt does not give much detail about what are the functions being testing by this testcase until one looks at the --TEST-- section of the file. It would be nice to have the name of the testcase accomodate name of the functions that are being tested. For example if 009.phpt is written to test basic functionality of current() and next() functions, the better file name could be current_next_basic.phpt.
Well, aesthetically - yes, "current_next_basic" might look better to those who don't like numbers. But you still have to open the test and read its --TEST-- section contents to learn what exactly it's testing. That said, I'm happy with both func_b.phpt and func_basic.phpt (and even 009.phpt) =) We just need more tests, doesn't matter what their names look like. We're on it :-) Will probably have a few more questions on Unicode testing later, noticed that you are putting UEXPECT section in tests- but need to understand the implemenentation plan first...


« previous php.internals (#29431) next »