RE: [PHP-DEV] FW: php fastcgi

From: Date: Wed, 13 Jun 2007 17:08:04 +0000
Subject: RE: [PHP-DEV] FW: php fastcgi
References: 1 2  Groups: php.internals 
Request: Send a blank email to internals+get-30161@lists.php.net to get a copy of this message
Where is the propsed patch? I was thinking about a (not SAPI specific the subject indicates!!!!) modification to the php-output parts that sends a HTTP status "500" when a fatal error occurs and no output was yet send (SAPI did not start the response). I think there is no need for a configuration setting. A CGI program that crashes on startup creates error 500, a servlet/JSP that does not startup creates error 500,... In principle SAPI should return a FAILURE to the webserver from the handler function and set the status code before. The webserver then generates the default error page. ----- Uwe Schindler thetaphi@php.net - http://www.php.net NSAPI SAPI developer Bremen, Germany > -----Original Message----- > From: Dmitry Stogov [mailto:dmitry@zend.com] > Sent: Wednesday, June 13, 2007 6:54 PM > To: ceo@l-i-e.com > Cc: 'internals Mailing List'; 'Stanislav Malyshev'; 'Andrei > Nigmatulin' > Subject: RE: [PHP-DEV] FW: php fastcgi > > Configuaratin option make sense, but PHP already has too many > configuration > options especialliy for error reprting. > I would like to avoid new ones. > > Thanks. Dmitry. > > > -----Original Message----- > > From: Richard Lynch [mailto:ceo@l-i-e.com] > > Sent: Wednesday, June 13, 2007 8:17 PM > > To: Dmitry Stogov > > Cc: 'internals Mailing List'; Stanislav Malyshev; Andrei Nigmatulin > > Subject: Re: [PHP-DEV] FW: php fastcgi > > > > > > On Wed, June 13, 2007 2:07 am, Dmitry Stogov wrote: > > > Current time most PHP instalations use setting > > 'display_error=0'. This > > > setting hides errors from user but may send to him just a > > blank page. > > > > > > The proposed patch sends HTTP 500 response on errors > > instead of blank > > > pages. The pages that already wrote something are not affectd. > > > > > > Any objections or additions? > > > > This sounds perfectly reasonable... > > > > But I suspect some users might prefer a 404 or a customizable > > response of some type... > > > > At the risk of incurring the wrath of list members, perhaps > > yet another php.ini configuration switch could be considered?... > > > > I wouldn't hold up the 500 patch for long with this kind of > > discussion, but it's worth taking a few minutes to consider, I think. > > > > -- > > Some people have a "gift" link here. > > Know what I want? > > I want you to buy a CD from some indie artist. > > http://cdbaby.com/browse/from/lynch > > Yeah, I get a buck. So? > > > > -- > PHP Internals - PHP Runtime Development Mailing List > To unsubscribe, visit: http://www.php.net/unsub.php

« previous php.internals (#30161) next »