API change has me confused.
| From: | BuildSmart | Date: | Thu, 30 Aug 2007 05:20:18 +0000 |
| Subject: | API change has me confused. | ||
| Groups: | php.internals | ||
| Request: | Send a blank email to internals+get-31975@lists.php.net to get a copy of this message | ||
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
I grabbed the latest version of the rar extension becasue there were too many issues with the earlier version.
It fails to compile, I've compared the offending section with the earlier code and it's identical in syntax ( php_rar_class_functions was renamed to rar_functions, I tried renaming but the results were the same so it's not a naming issue ).
I've checked some other modules for syntax and they're the same so what am I missing?
/php-src/ext/rar/rar.cpp: In function 'int zm_startup_rar(int, int)':
/php-src/ext/rar/rar.cpp:677: error: invalid conversion from 'void*' to 'UChar*'
ext/rar/rar.cpp:
673:PHP_MINIT_FUNCTION(rar)
674:{
675: zend_class_entry rar_class_entry;
676:
677: INIT_CLASS_ENTRY(rar_class_entry, "RarEntry", rar_functions);
678: rar_class_entry_ptr = zend_register_internal_class(&rar_class_entry TSRMLS_CC);
679:
- -- BuildSmart
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (Darwin)
iD8DBQFG1lOT0hzWbkf0eKgRAtnTAJsHswnxY7cS3mFgWUwsTEllUv33BQCeO70A
qvz6vhAsc6V1TKIkbNBEmZU=
=aqdz
-----END PGP SIGNATURE-----